In-Class Exercise 04 — Numbering Systems

Topics: Numbering Systems

Summary:

For this assignment, you will perform some basic calculations and analyses on text and digital
images using binary and hexadecimal numbers. By the end of this assignment, you should have
a basic understanding of how text and image file sizes are calculated and how media is encoded
in binary and hexadecimal form.

Reminders:
e Please don’t hesitate to call on the instructor if you need help. You are also welcome and
encouraged to confer with your classmates if the instructor is busy helping somebody else.

e You are welcome to take breaks at your discretion while working on this assignment.
However, you are not allowed to leave for the day until the class period has ended or you
have completed the assignment and turned it in.

e The instructor is always happy to look over any assignment upon request.

Please read each step carefully before completing it. Be sure to observe the rules of spelling,
grammar, capitalization, and punctuation in your write-up.

Taking Screenshots:
This assignment asks you to take some screenshots. The screenshot tools are as follows:

e Windows: Start Menu -> All Programs -> Accessories -> Snipping Tool
e Mac: Command + Shift + 4 (puts an image file directly on your desktop)



Instructions:

Part I: ASCII
1. Getinto groups of two.

2. Both members of your team need to choose a word or short phrase (at least six letters total
and no more than three words!). It can be anything not obscene or offensive, but don’t tell
your partner what you chose. | recommend writing the word or phrase down someplace
where your partner can’t see it, such as a notepad or on your smartphone or tablet.

3. Download and open up the ICEO4_Template file and save it as LastnameFirstname_ICE04
(ex. CuneoJoshua_ICE04).

a. Atthe top of your document, record your name and your partner’s name.
b. Only when you are done with Part I, record your message.

4. In your browser, go to http://www.asciichart.com/. Use this table to write out your choice

from step 2 in ASCIl decimal characters (look under the Dec column on the table). For
example,
Forbidden Planet
would translate into

70 111 114 98 105 100 100 101 110 32 80 108 97 110 101 116

Please be sure to use capital and lowercase characters where appropriate and to include
spaces and punctuation marks. \Write these numbers down in your text/Word file.

5. In your browser, go to http://www.mathsisfun.com/binary-decimal-hexadecimal-

converter.html. Use this tool to translate your decimal numbers from Step 4 into binary and

hexadecimal humbers.

Binary type: | 0001 B
Type your decimal numbers here, one

Binary: 01000110 / -
at a time.
70

Decimal: I

Hexadecimal: 46

& 20135 MathslsFun.com w77


http://www.asciichart.com/
http://www.mathsisfun.com/binary-decimal-hexadecimal-converter.html
http://www.mathsisfun.com/binary-decimal-hexadecimal-converter.html

6.

8.

You are also welcome to use Windows or Mac Calculator to complete this step:
e Windows: Start -> All Programs -> Accessories -> Calculator, then put the Calculator
in Programming mode (View -> Programmer)
e Mac: Finder -> Go -> Applications -> Calculator

Be sure to add enough leading zeros so that each binary number has eight digits. For
instance, if the conversion tool gives me 1000110, | would write down 01000110. You can
have the converter do this for you by clicking on the drop-down menu and choosing the
“0001” option.

Binary type: | 0001 -
Sinary: [
Decimal: signed 16-bit

signed 32-bit

Continuing the example from Step 4, | would get

Binary:
01000110 01101111 01110010 01100010 01101001 01100100 01100100
01100101 01101110 00100000 01010000 01101100 01100001 01101110
01100101 01110100
Hexadecimal:
46 6F 72 62 69 64 64 65 6E 20 50 6C 61 6E 65 74

Record your binary and hexadecimal numbers in your Word file.

Send your hexadecimal numbers only to your partner (email, Google Docs, or thumb drives
are great ways to share this information).

Copy and paste your partner’s hexadecimal code into your own Word file.

Take your partner’s hexadecimal code and run steps 4 — 5 in reverse. Use your converter
from Step 5 to turn the hexadecimal numbers back into decimal numbers (don’t worry about
binary), then use the ASCII table from Step 4 to decode the message. Be sure to record both
the decimal numbers and the decoded phrase in your Word file.



9. Check with your partner that you have decoded his or her message correctly.

10. In your Word file, answer the following questions:

a. How many characters (including spaces and punctuation marks) are in your partner’s

message?

b. How many bytes (NOT bits) does this message take up in memory?

Part Il: Images
11. Go online and find any photograph of your choice. It must meet the following criteria:

a. It must be at least 100 px wide by 100 px tall, but larger is better.

It is in color.
c. It has a lot of image complexity, so almost any Facebook photo would do, but an

animation frame or drawing would not.
d. The background is not black, white, or another solid color.

Download the photo to your computer and rename it to LastnameFirstname_ICE04_Original.
Note: If you’re not sure if your image will qualify, please check with the instructor.
12. Open up your photo in GIMP, click on Image -> Flatten Image, and export it as an

uncompressed bitmap (File -> Export As -> Select File Type (By Extension), then choose
“Windows BMP Image”) named LastnameFirstname_ICE04_UncompressedOriginal.

Il Export Image 3 )
Note that your file should
Name: Cuneoloshua_ICE4_UncompressedOriginal.bmp <
have a .bmp appended to the
- All export images [=] end when you select the
=l Select File Type (Windows BMP image) Windows BMP image option
File Type Extensions g
U S g T S
TarGA image tga
. i
Windows BMP image bmp
X BitMap image xbm,icen, bitmap
Help Export l | Cancel




13. In your browser, go to http://www.onlinehexeditor.com and upload your Bitmap file from

the previous step. Your screen should look something like the image below.
NOTE: The editor may not work correctly in browsers other than Firefox. If you have trouble
uploading the file, or you do not get a screen like the one below after upload, try again in

Firefox.

Take a screenshot of the hex editor and paste it into your Word document.

onlinehexeditor

files 00 01 02 03 04 05 06 07 08 09 0a Ob Oc 0d Oe Of L —
0000000000 B 4d 62 ec 04 00 00 00 00 00 7a 00 00 00 6c 00 [EMb.......z...1. -
0000000010 00 00 92 01 00 00 Ob 01 00 00 01 00 18 00 00 00 A e oz
0000000020 00 00 e8 eb 04 00 13 Ob 00 00 13 Ob 00 00 00 00
0000000030 00 00 00 00 00 00 42 47 52 73 00 00 00 00 00 00 int: 66
0000000040 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0000000050 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 intis 66
0000000060 00 00 00 00 00 00 00 00 00 00 02 00 00 00 00 00
0000000070 00 00 00 00 00 00 00 00 00 00 54 37 41 5b 3e 48 int, 66
0000000080 56 37 40 60 3f 48 61 3e 48 5c 37 41 65 3= 46 S
0000000090 38 40 60 36 3f 62 3b 43 68 42 48 58 34 3a 56 32 intse 66
0000000020 38 57 35 3b 54 32 38 69 47 4d 49 24 2c 46 21 29
0000000060 3 1b 23 36 15 1c 29 0d 13 20 06 Oc 18 00 06 14 uints 66
00000000co 00 03 14 00 05 11 00 04 10 00 03 Of 00 02 Oe 00
0000000040 01 10 00 01 10 00 01 Oe 00 01 0d 00 03 09 00 03 uint;s 66
000000000 08 00 02 06 00 02 05 00 02 03 00 02 02 01 03 00
00000000£0 01 03 00 00 02 00 01 03 00 01 03 03 02 04 03 02 uintsz 66
0000000100 04 04 01 03 04 01 03 03 00 02 01 01 01 01 01 01
0000000110 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 uintgs 66
0000000120 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01
0000000130 01 01 01 01 01 01 01 01 01 01 00 01 01 00 01 01 float
0000000140 00 01 01 00 01 01 00 01 01 00 01 01 00 01 01 00  .eevvvveeeeeecns
0000000150 01 01 00 01 01 00 01 01 00 01 01 00 00 00 00 00  .evevvveeeeennns toubie
0000000160 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ..evvveeeeeeeans Saeniig =
0000000170 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  .ewervreeeeeenns T
+
structure | view search  checksum
pg. Jpeg ~ [load ]
offset size type name value

14. Go back to GIMP. Create a new image file with the same width and height of your photo,
but fill it in with a solid color of your choice other than black, white, or grey.

HINT: With your photo still open in GIMP, go to File -> New. GIMP will remember the
dimensions of the last opened image and will create a new image with the same width and
height.

15. Export your image as an uncompressed Bitmap with the name
LastnameFirstname_ICE04_UncompressedBlank.

16. Go back to the online hex editor and upload your file from the previous step. Take another
screenshot and paste it into your Word document.


http://www.onlinehexeditor.com/

17. Describe the following:

a. What pattern do you see in the hex editor with your image from Step 15 uploaded?
b. Why does this pattern exist?

NOTE: Ignore the first few rows of numbers in the hex editor. This is header information.
Scroll down until you see numbers repeating in a predictable pattern.

18. Check the file sizes of your two Bitmap images. Both file sizes should be equal. In your
text/Word file, describe why.

HINT: Think of the three dimensions of each of the two images.

19. Assume that your Bitmap images are 24-bit (3 byte) color. Calculate the size of either one
using its width and height. Show your calculations and ensure that it is close to the file size
you looked up in the last step. Be sure to indicate correct units!

NOTE: You can get the width and height of an image by right-clicking on it and going to
Properties (Windows) or Get Info (Mac).

20. In your text/Word file, express the size of either of your Bitmap images in bits, bytes, KB,
MB, and GB. Show your calculations!

NOTE: Please do not use a conversion tool. Please do the calculation manually.

21. Go back to GIMP and open up the image you originally downloaded. Convert it to Indexed
Color (Image -> Mode -> Indexed) and choose the “Maximum number of colors” to be a
value of your choice between 8 and 32. Export your image as an uncompressed bitmap with
the name LastnameFirstname_ICE04_IndexedBitmap.

Record the following in your text/Word file:

What value did you choose for the maximum number of colors?
What changes did you notice in your image when you converted to Indexed Color?

c. What is the minimum number of bits you need to represent this many colors? (HINT:
This should be a single-digit value.)

d. In part ¢, how do you know what the minimum number of bits is? Show or describe
your calculations.



22. Save your files and turn them in on D2L. You should have the following five files:

JENES

LastnameFirstname_ICEO4.docx (Step 3)
LastnameFirstname_ICE04_Original (Step 11)
LastnameFirstname_ICE04_UncompressedOriginal.bmp (Step 12)
LastnameFirstname_ICE04_UncompressedBlank.bmp (Step 15)
LastnameFirstname_ICEO04_IndexedBitmap.bmp (Step 21)

23. When you are done with this assignment, you are free to leave.

Criteria:
Step | Points | Reason
3 4 | Word file, correctly named
Your message, in decimal, hexadecimal, and binary ONLY, of appropriate
8 | length
8 | Your partner’s message, in decimal and hexadecimal
8 | Your partner’s message, decoded
10a 5 | How many characters?
10b 5 | How many bytes?
11 4 | _Original: Photograph - 100+ px, color, no solid background, correct name
12 4 | _UncompressedOriginal: Uncompressed BMP of photo, correctly named
13 4 | Screenshot of hex editor of first uncompressed original image
15 4 | _UncompressedBlank: Solid color version of BMP, correctly named
16 4 | Screenshot of hex editor of uncompressed solid color image
17a 5 | What pattern do you see?
17b 5 | Why does this pattern exist?
18 4 | Why are the two BMPs the same size
19 4 | Size, with calculations shown
20 4 | BMP size in bits, B, KB, MB, GB
21 4 | _IndexedBitmap: Indexed photo, correctly named
21a 4 | Value between 8 and 32
21b 4 | What changes did you notice in the image?
21c 4 | Minimum number of bits to index photo
21d 4 | How do you know what the minimum number of bits is?




